Child pages
  • Requisitos de uso do serviço compute
Skip to end of metadata
Go to start of metadata

 

Portal Web

O portal web do serviço compute@RNP deve ser compatível com qualquer navegador moderno, mas é possível que alguns navegadores não renderizem partes da interface de forma confiável dependendo de seu suporte de padrões web. Para melhores resultados, é recomendável um dos seguintes navegadores:

  • Internet Explorer versões 10 e 11;
  • Firefox versão 31 ou posterior;
  • Google Chrome versão 36.0.1985 ou posterior;
  • Safari 6 ou posterior.

API

Para utilizar a API não há nenhum requisito tecnológico específico, porém você deve ter o seguinte para começar:

  • URL do serviço que responde pela API;
  • A API Key e a Secret Key de sua conta. Isso deve ser gerado por você no portal;
  • Familiaridade com HTTP GET / POST e strings de consulta;
  • Conhecimento de XML ou JSON;
  • O conhecimento de uma linguagem de programação que pode gerar solicitações HTTP, por exemplo, Java ou PHP.

CLI (Cloudmonkey)

A CLI cloudmonkey é independente de plataforma e requer o Python 2.6 ou superior e tem as seguintes dependências:

  • readline;
  • solicitações;
  • pygments;
  • prettytable;
  • argcomplete.
  • No labels